shithub: sox

ref: 5d2a07fe5c656961e9ee9d3e9bead8eb584ae0b6
dir: /debian/rules/

View raw version
#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-

DEB_TAR_SRCDIR := sox-14.0.0

include /usr/share/cdbs/1/rules/tarball.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
#include /usr/share/cdbs/1/rules/simple-patchsys.mk

DEB_CONFIGURE_SCRIPT_ENV += CFLAGS="-D_REENTRANT"
DEB_CONFIGURE_EXTRA_FLAGS := --disable-lame
# Takes care of postinst-has-useless-call-to-ldconfig for libsox-fmt-*
DEB_DH_MAKESHLIBS_ARGS := -Xfmt

binary-post-install/sox::
	chrpath -d debian/sox/usr/bin/sox

binary-post-install/libsox0::
	chrpath -d debian/libsox0/usr/lib/lib*.so.*

binary-post-install/libsox-fmt-all::
	chrpath -d debian/libsox-fmt-*/usr/lib/sox/libsox_fmt_*.so.*