shithub: sox

ref: 78e008ae4a3ee1ba9ef2d0d56959369006b48dc2
dir: /debian/rules/

View raw version
#!/usr/bin/make -f
# -*- mode: makefile; coding: utf-8 -*-

DEB_TAR_SRCDIR := sox-14.3.1

include /usr/share/cdbs/1/rules/tarball.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk

CPPFLAGS += -I/usr/include/ffmpeg
DEB_CONFIGURE_EXTRA_FLAGS := --without-lame --with-distro="$(shell dpkg-vendor --query vendor)" --with-dyn-default
# Takes care of postinst-has-useless-call-to-ldconfig for libsox-fmt-*
DEB_DH_MAKESHLIBS_ARGS := -Xfmt